
Microsoft Excel 2019 cheat sheet

Frequently used shortcuts
Ctrl + W Close a workbook

Ctrl + O Open a workbook

Alt + H Go to the Home tab

Ctrl + S Save a workbook

Ctrl + C Copy

Ctrl + V Paste

Ctrl + Z Undo

Del Remove cell contents

Alt + H then H Choose a fill color

Ctrl + X Cut

Alt + N Go to Insert tab

Ctrl + B Bold

Alt + H then A 
then C

Center align cell contents

Alt + P Go to Page Layout tab

Alt + A Go to Data tab

Alt + W Go to View tab

Shift + F10 or 
Context menu key

Open context menu

Alt + H then B Add borders

Alt + H then D 
then C

Delete column

Alt + M Go to Formula tab

Ctrl + 9 Hide the selected rows

Ctrl + 0 Hide the selected columns

Ctrl + Shift + F3 Create names from selection

Alt + D then F 
then A

Advanced filter

Ribbon: Access keys for tabs
Alt + Q then enter the search term: 

Open the Tell me box on the 
Ribbon and type a search term 
for assistance or Help content

Alt + F Open the File page and use 
Backstage view

Alt + H Open the Home tab and format 
text and numbers and use the 
Find tool

Open the Insert tab and insert Alt + N

PivotTables, charts, add-ins, 
Sparklines, pictures, shapes, 
headers, or text boxes

Alt + P Open the Page Layout tab and 
work with themes, page setup, 
scale, and alignment

Alt + M Open the Formulas tab and 
insert, trace, and customize 
functions and calculations

Alt + A Open the Data tab and connect 
to, sort, filter, analyze, and work 
with data

Alt + R Open the Review tab and check 
spelling, add comments, and 
protect sheets and workbooks

Alt + W Open the View tab and preview 
page breaks and layouts, show 
and hide gridlines and headings, 
set zoom magnification, manage 
windows and panes, and view 
macros

Ribbon: Work in the ribbon with the 
keyboard

Alt (to move to a different tab, use 
access keys or the arrow keys) 
Select the active tab of the 
ribbon, and activate the access 
keys.

F10 To move to a different tab, use 
access keys or the arrow keys. 
 Select the active tab of the 
ribbon, and activate the access 
keys.

Tab or Shift + Tab Move the focus to commands on 
the ribbon

Arrow keys Move among the items on the 
Ribbon

Space or Enter Activate a selected button

Down arrow Open the list for a selected 
command

Alt + Down arrow Open the menu for a selected 
button

Down arrow When a menu or submenu is 
open, move to the next 
command
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Ctrl + F1 Expand or collapse the ribbon

Shift + F10 or 
Context menu key

Open a context menu

Left arrow Move to the submenu when a 
main menu is open or selected

Navigating in cells
Shift + Tab Move to the previous cell in a 

worksheet or the previous option 
in a dialog box

Up arrow Move one cell up in a worksheet

Down arrow Move one cell down in a 
worksheet

Left arrow Move one cell left in a worksheet

Right arrow Move one cell right in a 
worksheet

Ctrl + Arrow keys Move to the edge of the current 
data region in a worksheet

End then Arrow 
keys

Enter End mode, move to the 
next nonblank cell in the same 
column or row as the active cell, 
and turn off End mode. If the 
cells are blank, move to the last 
cell in the row or column

Ctrl + End Move to the last cell on a 
worksheet, to the lowest used 
row of the rightmost used 
column

Ctrl + Shift + End Extend the selection of cells to 
the last used cell on the 
worksheet (lower-right corner)

Home + Scroll 
Lock

Move to the cell in the upper-left 
corner of the window when Scroll 
Lock is turned on

Ctrl + Home Move to the beginning of a 
worksheet

Page Down Move one screen down in a 
worksheet

Ctrl + Page Down Move to the next sheet in a 
workbook

Alt + Page Down Move one screen to the right in a 
worksheet

Page Up Move one screen up in a 
worksheet

Move one screen to the left in a Alt + Page Up

worksheet

Ctrl + Page Up Move to the previous sheet in a 
workbook

Tab Move one cell to the right in a 
worksheet. Or, in a protected 
worksheet, move between 
unlocked cells

Ctrl + Alt + 5 and then the Tab key repeatedly: 
Cycle through floating shapes, 
such as text boxes or images

Esc Exit the floating shape navigation 
and return to the normal 
navigation

Formatting cells
Ctrl + 1 Open the Format Cells dialog 

box

Ctrl + Shift + F or 
Ctrl + Shift + P

Format fonts in the Format Cells 
dialog box

F2 Edit the active cell and put the 
insertion point at the end of its 
contents. Or, if editing is turned 
off for the cell, move the 
insertion point into the formula 
bar. If editing a formula, toggle 
Point mode off or on so you can 
use arrow keys to create a 
reference

Shift + F2 Add or edit a cell comment

Ctrl + Shift + + Open the Insert dialog to insert 
blank cells

Ctrl + - Open the Delete dialog box to 
delete selected cells

Ctrl + Shift + : Enter the current time

Ctrl + ; Enter the current date

Ctrl + ` Switch between displaying cell 
values or formulas in the 
worksheet

Ctrl + ' Copy a formula from the cell 
above the active cell into the cell 
or the Formula Bar

Ctrl + X Move the selected cells

Ctrl + C Copy the selected cells

Ctrl + V Paste content at the insertion 
point, replacing any selection
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Ctrl + Alt + V Open the Paste Special dialog 
box

Ctrl + I or Ctrl + 3 Italicize text or remove italic 
formatting

Ctrl + B or Ctrl + 2 Bold text or remove bold 
formatting

Ctrl + U or Ctrl + 4 Underline text or remove 
underline

Ctrl + 5 Apply or remove strikethrough 
formatting

Ctrl + 6 Switch between hiding objects, 
displaying objects, and 
displaying placeholders for 
objects

Ctrl + Shift + & Apply an outline border to the 
selected cells

Ctrl + Shift + _ Remove the outline border from 
the selected cells

Ctrl + 8 Display or hide the outline 
symbols

Ctrl + D Use the Fill Down command to 
copy the contents and format of 
the topmost cell of a selected 
range into the cells below

Ctrl + Shift + ~ Apply the General number 
format

Ctrl + Shift + $ Apply the Currency format with 
two decimal places (negative 
numbers in parentheses)

Ctrl + Shift + % Apply the Percentage format 
with no decimal places

Ctrl + Shift + ^ Apply the Scientific number 
format with two decimal places

Ctrl + Shift + # Apply the Date format with the 
day, month, and year

Ctrl + Shift + @ Apply the Time format with the 
hour and minute, and AM or PM

Ctrl + Shift + ! Apply the Number format with 
two decimal places, thousands 
separator, and minus sign (-) for 
negative values

Ctrl + K Open the Insert hyperlink dialog

F7 Check spelling in the active 
worksheet or selected range

Display the Quick Analysis Ctrl + Q

options for selected cells that 
contain data

Ctrl + L or Ctrl + T Display the Create Table dialog 
box

Making selections and performing 
actions

Ctrl + A or Ctrl + 
Shift + Space

Select the entire worksheet

Ctrl + Shift + Page 
Down

Select the current and next sheet 
in a workbook

Ctrl + Shift + Page 
Up

Select the current and previous 
sheet in a workbook

Shift + Arrow keys Extend the selection of cells by 
one cell

Ctrl + Shift + 
Arrow keys

Extend the selection of cells to 
the last nonblank cell in the 
same column or row as the 
active cell, or if the next cell is 
blank, to the next nonblank cell

F8 Turn extend mode on and use 
the arrow keys to extend a 
selection. Press again to turn off

Shift + F8 Add a non-adjacent cell or range 
to a selection of cells by using 
the arrow keys

Alt + Enter Start a new line in the same cell

Ctrl + Enter Fill the selected cell range with 
the current entry

Shift + Enter Complete a cell entry and select 
the cell above

Ctrl + Space Select an entire column in a 
worksheet

Shift + Space Select an entire row in a 
worksheet

Ctrl + Shift + 
Space

Select all objects on a worksheet 
when an object is selected

Ctrl + Shift + 
Home

Extend the selection of cells to 
the beginning of the worksheet

Ctrl + A or Ctrl + 
Shift + Space

Select the current region if the 
worksheet contains data. Press 
a second time to select the 
current region and its summary 
rows. Press a third time to select 
the entire worksheet
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Ctrl + Shift + * Select the current region around 
the active cell or select an entire 
PivotTable report

Home Select the first command on the 
menu when a menu or submenu 
is visible

Ctrl + Y Repeat the last command or 
action, if possible

Ctrl + Z Undo the last action

Working with data, functions, and 
the formula bar

Ctrl + Shift + * Select an entire PivotTable 
report

F2 Edit the active cell and put the 
insertion point at the end of its 
contents. Or, if editing is turned 
off for the cell, move the 
insertion point into the formula 
bar. If editing a formula, toggle 
Point mode off or on so you can 
use arrow keys to create a 
reference

Ctrl + Shift + U Expand or collapse the formula 
bar

Esc Cancel an entry in the cell or 
Formula Bar

Enter Complete an entry in the formula 
bar and select the cell below

Ctrl + End Move the cursor to the end of the 
text when in the formula bar

Ctrl + Shift + End Select all text in the formula bar 
from the cursor position to the 
end

F9 Calculate all worksheets in all 
open workbooks

Shift + F9 Calculate the active worksheet

Ctrl + Alt + F9 Calculate all worksheets in all 
open workbooks, regardless of 
whether they have changed 
since the last calculation

Ctrl + Alt + Shift + 
F9

Check dependent formulas, and 
then calculate all cells in all open 
workbooks, including cells not 
marked as needing to be 
calculated

Alt + Shift + F10 Display the menu or message for 
an Error Checking button

Ctrl + A Display the Function Arguments 
dialog box when the insertion 
point is to the right of a function 
name in a formula

Ctrl + Shift + A Insert argument names and 
parentheses when the insertion 
point is to the right of a function 
name in a formula

Ctrl + E Invoke Flash Fill to automatically 
recognize patterns in adjacent 
columns and fill the current 
column

F4 Cycle through all combinations 
of absolute and relative 
references in a formula if a cell 
reference or range is selected

Shift + F3 Insert a function

Ctrl + Shift + " Copy the value from the cell 
above the active cell into the cell 
or the formula bar

Alt + F1 Create an embedded chart of the 
data in the current range

F11 Create a chart of the data in the 
current range in a separate 
Chart sheet

Alt + M then M M then D: Define a name to use 
in references.

F3 Paste a name from the Paste 
Name dialog box (if names have 
been defined in the workbook)

Enter Move to the first field in the next 
record of a data form

Alt + F8 Create, run, edit, or delete a 
macro

Alt + F11 Open the Microsoft Visual Basic 
For Applications Editor

Function keys
F1 Displays the Excel Help task 

pane

Ctrl + F1 Displays or hides the ribbon

Alt + F1 Creates an embedded chart of 
the data in the current range.
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Alt + Shift + F1 Inserts a new worksheet

F2 Edit the active cell and put the 
insertion point at the end of its 
contents. Or, if editing is turned 
off for the cell, move the 
insertion point into the formula 
bar. If editing a formula, toggle 
Point mode off or on so you can 
use arrow keys to create a 
reference

Shift + F2 Adds or edits a cell comment

Ctrl + F2 Displays the print preview area 
on the Print tab in the Backstage 
view

F3 Displays the Paste Name dialog 
box. Available only if names 
have been defined in the 
workbook

Shift + F3 Displays the Insert 
Function dialog box

F4 Repeats the last command or 
action, if possible

F4 When a cell reference or range 
is selected in a formula, F4 
cycles through all the various 
combinations of absolute and 
relative references

Ctrl + F4 Closes the selected workbook 
window

Alt + F4 Closes Excel

F5 Displays the Go To dialog box

Ctrl + F5 Restores the window size of the 
selected workbook window

F6 Switches between the 
worksheet, ribbon, task pane, 
and Zoom controls. In a 
worksheet that has been split, F6 
includes the split panes when 
switching between panes and 
the ribbon area

Shift + F6 Switches between the 
worksheet, Zoom controls, task 
pane, and ribbon

Ctrl + F6 Switches to the next workbook 
window when more than one 
workbook window is open

Opens the Spelling dialog box to F7

check spelling in the active 
worksheet or selected range

Ctrl + F7 Performs the Move command on 
the workbook window when it is 
not maximized. Use the arrow 
keys to move the window, and 
when finished press Enter, or 
Esc to cancel

F8 Turns extend mode on or off. In 
extend mode, Extended 
Selection appears in the status 
line, and the arrow keys extend 
the selection

Shift + F8 Enables you to add a 
nonadjacent cell or range to a 
selection of cells by using the 
arrow keys

Ctrl + F8 Performs the Size command 
when a workbook is not 
maximized

Alt + F8 Displays the Macro dialog box to 
create, run, edit, or delete a 
macro

F9 Calculates all worksheets in all 
open workbooks

Shift + F9 Calculates the active worksheet

Ctrl + Alt + F9 Calculates all worksheets in all 
open workbooks, regardless of 
whether they have changed 
since the last calculation

Ctrl + Alt + Shift + 
F9

Rechecks dependent formulas, 
and then calculates all cells in all 
open workbooks, including cells 
not marked as needing to be 
calculated

Ctrl + F9 Minimizes a workbook window to 
an icon

F10 Turns key tips on or off (Pressing 
Alt does the same thing)

Shift + F10 Displays the shortcut menu for a 
selected item

Alt + Shift + F10 Displays the menu or message 
for an Error Checking button

Ctrl + F10 Maximizes or restores the 
selected workbook window

Creates a chart of the data in the 
current range in a separate 

F11
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Chart sheet

Shift + F11 Inserts a new worksheet

Alt + F11 Opens the Microsoft Visual Basic 
For Applications Editor, in which 
you can create a macro by using 
Visual Basic for Applications 
(VBA)

F12 Displays the Save As dialog box

Other useful shortcut keys
Alt Displays the Key Tips (new 

shortcuts) on the ribbon

For example, Alt, W, P switches the worksheet to 
Page Layout view.

Alt, W, L switches the worksheet to Normal view.

Alt, W, I switches the worksheet to Page Break 
Preview view.

Arrow keys Move one cell to a direction you 
press in a  worksheet

Ctrl + Arrow keys Moves to the edge of the current 
data region in a worksheet

Shift + Arrow keys Extends the selection of cells by 
one cell

Ctrl + Shift + 
Arrow keys

Extends the selection of cells to 
the last nonblank cell in the 
same column or row as the 
active cell, or if the next cell is 
blank, extends the selection to 
the next nonblank cell

Left arrow / Right 
arrow

Selects the tab to the left or right 
when the ribbon is selected. 
When a submenu is open or 
selected, these arrow keys 
switch between the main menu 
and the submenu. When a 
ribbon tab is selected, these 
keys navigate the tab buttons

Up arrow / Down 
arrow

Selects the previous or next 
command when a menu or 
submenu is open. When a 
ribbon tab is selected, these 
keys navigate up or down the tab 
group

In a dialog box, arrow keys move 
between options in an open 
drop-down list, or between 

Arrow keys

options in a group of options

Down arrow or Alt 
+ Down arrow

Opens a selected drop-down list

Backspace Deletes one character to the left 
in the Formula Bar

Backspace Also clears the content of the 
active cell

Backspace In cell editing mode, it deletes 
the character to the left of the 
insertion point

Del Removes the cell contents (data 
and formulas) from selected cells 
without affecting cell formats or 
comments

Del In cell editing mode, it deletes 
the character to the right of the 
insertion point

End Turns End mode on or off. In 
End mode, you can press an 
arrow key to move to the next 
nonblank cell in the same 
column or row as the active cell. 
End mode turns off automatically 
after pressing the arrow key. 
Make sure to press End again 
before pressing the next arrow 
key. End mode is shown in the 
status bar when it is on

End If the cells are blank, pressing 
End followed by an arrow key 
moves to the last cell in the row 
or column

End End also selects the last 
command on the menu when a 
menu or submenu is visible

Ctrl + End moves to the last cell on a 
worksheet, to the lowest used 
row of the rightmost used 
column. If the cursor is in the 
formula bar, this shortcut moves 
the cursor to the end of the text

Extends the selection of cells to 
the last used cell on the 
worksheet (lower-right corner). If 
the cursor is in the formula bar, 
this shortcut selects all text in the 
formula bar from the cursor 
position to the end—this does 

Ctrl + Shift + End
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not affect the height of the 
formula bar

Enter Completes a cell entry from the 
cell or the Formula Bar, and 
selects the cell below (by 
default)

Enter In a data form, it moves to the 
first field in the next record

Enter Opens a selected menu (press 
F10 to activate the menu bar) or 
performs the action for a 
selected command

Enter In a dialog box, it performs the 
action for the default command 
button in the dialog box (the 
button with the bold outline, often 
the OK button)

Alt + Enter Starts a new line in the same cell

Ctrl + Enter Fills the selected cell range with 
the current entry

Shift + Enter Completes a cell entry and 
selects the cell above

Esc Cancels an entry in the cell or 
Formula Bar

Esc Closes an open menu or 
submenu, dialog box, or 
message window

Esc It also closes full screen mode 
when this mode has been 
applied, and returns to normal 
screen mode to display the 
ribbon and status bar again

Home Moves to the beginning of a row 
in a worksheet

Home Moves to the cell in the upper-
left corner of the window when 
Scroll Lock is turned on

Home Selects the first command on the 
menu when a menu or submenu 
is visible

Ctrl + Home Moves to the beginning of a 
worksheet

Ctrl + Shift + 
Home

Extends the selection of cells to 
the beginning of the worksheet

Page Down Moves one screen down in a 
worksheet

Alt + Page Down Moves one screen to the right in 
a worksheet

Ctrl + Page Down Moves to the next sheet in a 
workbook

Ctrl + Shift + Page 
Down

Selects the current and next 
sheet in a workbook

Page Up Moves one screen up in a 
worksheet

Alt + Page Up Moves one screen to the left in a 
worksheet

Ctrl + Page Up Moves to the previous sheet in a 
workbook

Ctrl + Shift + Page 
Up

Selects the current and previous 
sheet in a workbook

Space In a dialog box, performs the 
action for the selected button, or 
selects or clears a check box

Ctrl + Space Selects an entire column in a 
worksheet

Shift + Space Selects an entire row in a 
worksheet

Ctrl + Shift + 
Space

Selects the entire worksheet

Ctrl + Shift + 
Space

If the worksheet contains data, 
this shortcut selects the current 
region. Pressing Ctrl + Shift + 
Spacebar a second time selects 
the current region and its 
summary rows. Pressing Ctrl + 
Shift + Spacebar a third time 
selects the entire worksheet

Ctrl + Shift + 
Space

When an object is selected, this 
shortcut selects all objects on a 
worksheet

Alt + Space Displays the Control menu for 
the Excel window

Tab Moves one cell to the right in a 
worksheet

Tab Moves between unlocked cells in 
a protected worksheet

Tab Moves to the next option or 
option group in a dialog box

Shift + Tab Moves to the previous cell in a 
worksheet or the previous option 
in a dialog box

Switches to the next tab in dialog Ctrl + Tab
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box

Ctrl + Shift + Tab Switches to the previous tab in a 
dialog box

CTRL combination shortcut keys
Ctrl + Page Up Switches between worksheet 

tabs, from left-to-right

Ctrl + Page Down Switches between worksheet 
tabs, from right-to-left

Ctrl + Shift + ( Unhides any hidden rows within 
the selection

Ctrl + Shift + ) Unhides any hidden columns 
within the selection

Ctrl + Shift + & Applies the outline border to the 
selected cells

Ctrl + Shift + _ Removes the outline border from 
the selected cells

Ctrl + Shift + ~ Applies the General number 
format

Ctrl + Shift + $ Applies the Currency format with 
two decimal places (negative 
numbers in parentheses)

Ctrl + Shift + % Applies the Percentage format 
with no decimal places

Ctrl + Shift + ^ Applies the Exponential number 
format with two decimal places

Ctrl + Shift + # Applies the Date format with the 
day, month, and year

Ctrl + Shift + @ Applies the Time format with the 
hour and minute, and AM or PM

Ctrl + Shift + ! Applies the Number format with 
two decimal places, thousands 
separator, and minus sign (-) for 
negative values

Ctrl + Shift + * Selects the current region 
around the active cell (the data 
area enclosed by blank rows and 
blank columns). In a PivotTable, 
it selects the entire PivotTable 
report

Ctrl + Shift + : Enters the current time

Ctrl + Shift + " Copies the value from the cell 
above the active cell into the cell 
or the Formula Bar

Displays the Insert dialog box to Ctrl + Shift + +

insert blank cells

Ctrl + - (-)  Displays the Delete dialog 
box to delete the selected cells

Ctrl + ; Enters the current date

Ctrl + ` Alternates between displaying 
cell values and displaying 
formulas in the worksheet

Ctrl + ' Copies a formula from the cell 
above the active cell into the cell 
or the Formula Bar

Ctrl + 1 Displays the Format Cells dialog 
box

Ctrl + 2 Applies or removes bold 
formatting

Ctrl + 3 Applies or removes italic 
formatting

Ctrl + 4 Applies or removes underlining

Ctrl + 5 Applies or removes strikethrough

Ctrl + 6 Alternates between hiding 
objects, displaying objects, and 
displaying placeholders for 
objects

Ctrl + 8 Displays or hides the outline 
symbols

Ctrl + 9 Hides the selected rows

Ctrl + 0 Hides the selected columns

Ctrl + A Selects the entire worksheet

Ctrl + A If the worksheet contains data, 
this shortcut selects the current 
region. Pressing it a second time 
selects the current region and its 
summary rows. Pressing it third 
time selects the entire worksheet

Ctrl + A When the insertion point is to the 
right of a function name in a 
formula, displays the Function 
Arguments dialog box

Ctrl + Shift + A Inserts the argument names and 
parentheses when the insertion 
point is to the right of a function 
name in a formula

Ctrl + B Applies or removes bold 
formatting

Ctrl + C Copies the selected cells

Ctrl + C then Ctrl + Display the Clipboard

Page 8 of 9



C

Ctrl + D Uses the Fill Down command to 
copy the contents and format of 
the topmost cell of a selected 
range into the cells below.

Ctrl + F Displays the Find and Replace 
dialog box, with the Find tab 
selected

Shift + F5 Also displays Find tab

Shift + F4 Repeats the last Find action

Ctrl + Shift + F Opens the Format Cells dialog 
box with the Font tab selected

Ctrl + G or F5 Displays the Go To dialog box

Ctrl + H Displays the Find and Replace 
dialog box, with the Replace tab 
selected

Ctrl + I Applies or removes italic 
formatting

Ctrl + K Displays the Insert Hyperlink 
dialog box for new hyperlinks or 
the Edit Hyperlinkdialog box for 
selected existing hyperlinks

Ctrl + N Creates a new, blank workbook

Ctrl + O Displays the Open dialog box to 
open or find a file

Ctrl + Shift + O Selects all cells that contain 
comments

Ctrl + P Displays the Print dialog box

Ctrl + Shift + P Opens the Format Cells dialog 
box with the Font tab selected

Ctrl + R Uses the Fill Right command to 
copy the contents and format of 
the leftmost cell of a selected 
range into the cells to the right

Ctrl + S Saves the active file with its 
current file name, location, and 
file format

Ctrl + T Displays the Create Table dialog 
box

Ctrl + U Applies or removes underlining

Ctrl + Shift + U Switches between expanding 
and collapsing of the formula bar

Inserts the contents of the 
Clipboard at the insertion point 
and replaces any selection. 

Ctrl + V

Available only after you have cut 
or copied an object, text, or cell 
contents

Ctrl + Alt + V Displays the Paste 
Special dialog box. Available 
only after you have cut or copied 
an object, text, or cell contents 
on a worksheet or in another 
program

Ctrl + W Closes the selected workbook 
window

Ctrl + X Cuts the selected cells

Ctrl + Y Repeats the last command or 
action, if possible

Ctrl + Z Uses the Undo command to 
reverse the last command or to 
delete the last entry that you 
typed

Ctrl + Shift + Z Uses 
the Undo or Redo command to 
reverse or restore the last 
automatic correction when 
AutoCorrect Smart Tags are 
displayed

Bonus tips
Shift + Left click To open a template as a 

template file and edit it (instead 
of saving it as .xlsx), right click 
the file and Shift (plus) click to 
"Open" menu item

Ctrl + J You can use this shortcut to split 
cells with multiple rows into 
columns with Alt + Enter while 
converting text to columns. Go to 
Data > Convert text to columns > 
Delimited and click "More" box 
then press Ctrl + J
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