
OriginLab Origin (2024) cheat sheet

Project
Ctrl + N File: New...

Ctrl + Alt + I File: New: Image: Image/Video...

Ctrl + Alt + T File: New: Image: Multiple Image 
Files...

Ctrl + Alt + L File: New: Image: Web Image...

Ctrl + O File: Open...

Ctrl + P File : Print

Ctrl + S File : Save Project

Ctrl + F4 Close the active 
worksheet/graph/matrix window

Ctrl + F6 Go to Next window

Alt + 1 View : Project Explorer

Alt + 2 View : Results Log

Alt + 3 View : Command Window

Alt + 3 Window : Command Window

Alt + 4 View : Code Builder

Alt + 5 View : Quick Help

Alt + 6 View : Messages Log

Alt + 7 View : Smart Hint Log

Alt + 8 View : Object Manager

Alt + 9 View : Apps

Alt + Shift + 3 Window : Script Window

Ctrl + Alt + Z Window : Return to Last Window

F2 Project Explorer: right click on 
folder or window and choose 
Rename

Ctrl + N Switch between LN (Long Name) 
and SN (Short Name) toggle 
mode when in-place editing 
workbook name in Project 
Explorer.

F3 PE: Right-click on Folder(Find)

Ctrl + Tab Navigate between different 
windows in the same folder, 
including the floating windows.

Ctrl + Tab Toggled on the window from the 
last active window, and ending at 
the first active window.

Ctrl + Shift + Tab Navigate between different 
windows in the same folder, 
including the floating windows.

Ctrl + Shift + Tab The order of toggling windows is 
inverse of Ctrl + Tab

Alt + Shift + R Right click the title bar of 
external Excel workbook and 
choose Update Origin.

Tool
Ctrl + K Data: Import from File : Single 

ASCII...

Ctrl + 3 Data: Import from File: Import 
Wizard

Ctrl + 4 Data : Re-import Directly

Ctrl + T View : Toolbars

Ctrl + U Preferences: Options

F7 Preferences: Theme Organizer

F8 Tools: Fitting Function Builder

F9 Tools: Fitting Function Organizer

F10 Help: App Center

F11 Help: Learning Center

Ctrl + Shift + O Tools: Color Manager

Ctrl + Shift + P Connectivity: Python Console

Alt + F5 Runs the [Main] section of User 
Files\Custom.ogs.

Ctrl + 0 Click the Pause Auto 
Recalculation button Button Auto 
Update On.png .

Editing
Ctrl + F Edit : Find

Ctrl + F Open the simple Find dialog. 
(Notes)

Ctrl + G Edit : Go to

Ctrl + H Edit : Replace

Ctrl + H Open the simple Replace dialog. 
(Notes)

Ctrl + V Edit : Paste (Also in many 
context menus)

Ctrl + X Edit : Cut

Ctrl + Z Edit : Undo

Ctrl + Y Edit: Redo

Ctrl + Alt + B Edit : Button Edit Mode

Edit : Paste Link or Right-Click a Ctrl + Alt + V
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cell (paste link)

Del Edit : Clear

Ctrl + Left click Select discontinuous cells, or 
deselect selected cells

Ctrl + Del Enter NANUM ("--")

Alt + Double click Right-click on the object and 
select Properties

Alt + X When entering special 
characters into text labels and 
worksheet cells, enter the 
Unicode four-digit hex value and 
immediately press ALT + X.

Ctrl + C Edit : Copy : Copy (Also in many 
context menus)

Ctrl + Alt + C (When Matrix/ Worksheet active) 
Edit : Copy : Copy (Full 
Precision)

Ctrl + Shift + C Edit: Copy : Copy (including 
label rows)

Ctrl + J Edit : Copy : Copy (formula)

Ctrl + Shift + J Edit : Copy (label rows)

Ctrl + Alt + J Edit : Copy : Copy (formula + 
label rows)

Ctrl + Shift + A Edit : Copy : Copy All

Ctrl + Shift + G Edit: Copy: Copy as 
Table(HTML/EMF)

Worksheet
Ctrl + D Column : Add New Columns...

Ctrl + H Insert Info Variable

Ctrl + L Data: Define Name (with 
worksheet active)

Ctrl + L Insert: Latex Equation (With 
worksheet cell selected in in-
place editing mode)

Ctrl + M While editing cell contents, 
opens the Character Map.

Ctrl + Q Column : Set Column Values...

Ctrl + Shift + Y Analysis : Fitting : Nonlinear 
Curve Fit

Ctrl + Shift + Q Column : Set Multiple Columns 
Values...

Ctrl + Shift + U Right-click on gray space of the 
worksheet, View: F(x)

F4 Format->Worksheet

Ctrl + Home Go to the cell in row 1, column 1 
of the active sheet.

Ctrl + End Go to the cell in the last 
occupied column and last 
occupied row in the active sheet.

Ctrl + F3 Data: Name Manager

Ctrl + F5 Set All Column Values

Ctrl + Page Up / 
Down

Navigate between different 
worksheets within the current 
workbook.

Ctrl + Down arrow Go to the last occupied cell in 
the column.

Ctrl + Up arrow Go to the first occupied cell in 
the column.

Ctrl + Shift + Left 
arrow

Extend the selection (whole 
columns or a block of cells) to 
the leftmost occupied column. If 
a block of cells is selected, the 
selection will only cover the 
same row range.

Ctrl + Shift + Right 
arrow

Extend the selection (whole 
columns or a block of cells) to 
the rightmost occupied column. If 
a block of cells is selected, the 
selection will only cover the 
same row range.

Ctrl + Space Extend to select the whole 
column.

Shift + Space Extend to select the whole row

Shift + Right arrow Select the column to the left or 
right of the currently-selected 
column. Each press of the arrow 
key selects another column. 
Hold to scroll selection.

Shift + Up arrow / 
Down arrow

Select the row up or down from 
the currently-selected row. Each 
press of the arrow key selects 
another row. Hold to scroll 
selection.

Ctrl + Shift + 
Down arrow

If whole rows or a block of cells 
are selected, extend the 
selection to the last occupied 
row. If a block of cells is 
selected, the selection will only 
cover the same column range.

Ctrl + Shift + If in the in-place edit mode in a 
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Down arrow worksheet cell (by double-
clicking inside the cell), highlight 
from cursor location to the end of 
the cell.

Ctrl + Shift + Up 
arrow

If whole rows or a block of cells 
are selected, extend the 
selection to the first occupied 
row. If a block of cells is 
selected, the selection will only 
cover the same column range.

Ctrl + Shift + Up 
arrow

If in the in-place edit mode in a 
worksheet cell (by double-
clicking inside the cell), highlight 
from cursor location to the 
beginning of the cell.

Ctrl + Shift + 
Home

If a worksheet cell is selected, 
extend selection to the cell in 
row 1, column 1.

Ctrl + Shift + 
Home

If in the in-place edit mode in a 
worksheet cell (by double-
clicking inside the cell), highlight 
from cursor location to the 
beginning of the cell.

Ctrl + Shift + End If a worksheet cell is selected, 
extend selection to the last cell in 
the rightmost occupied column, 
then to the last occupied row in 
the sheet.

Ctrl + Shift + End If in the in-place edit mode in a 
worksheet cell (by double-
clicking inside the cell), highlight 
from cursor location to the end of 
the cell.

Alt + Enter Double click in a cell to enter the 
in-place edit mode and press Alt 
+ Enter to insert a new line after 
the cursor.

Ctrl + Enter Fill a pre-selected group of cells 
by typing an entry in the active 
cell and pressing Ctrl + Enter. 
Supports non-contiguous 
selection.

When add Graph/Note/Matrix as 
Sheet, double click that sheet to 
pop-up Graph/Note/Matrix. Then 
press Ctrl + Enter to accept 
changes and close it. This 
behavior is the same as clicking 

Ctrl + Enter

the Return button in top-right 
corner.

Ctrl + F10 Click on the green lock icon and 
select Change Parameters: 
Reopen the Analysis dialog

Matrix
Ctrl + Q Column : Set Column Values...

Ctrl + Shift + C View->Show Column/Row

Ctrl + Shift + D View->Data Mode

Ctrl + Shift + I View->Image Mode

Ctrl + Shift + N Show Image Thumbnails

Ctrl + Shift + T Tools->Region of Interest Tools

Ctrl + Shift + X View->Show X/Y, when a matrix 
is active

Graph
Ctrl + A Select all layers in current 

graphs.

Ctrl + A If the window is Layout, then 
select all objects(label, graph, 
worksheet...).

Ctrl + Enter Exit in-place editing mode

Ctrl + G File:Export Graphs: Open Dialog

Ctrl + H Insert : Info Variable

Ctrl + L Insert : Latex Equation

Ctrl + J Edit : Copy Page

Ctrl + Alt + J Edit : Copy Page as Picture

Ctrl + L Graph : Reconstruct Legend

Ctrl + R Graph : Rescale to Show all

Ctrl + M Open the Symbol Map dialog

Ctrl + Y Analysis : Fitting : Nonlinear 
Curve Fit

Ctrl + 1 View : Page View

Ctrl + 2 View : Print View

Ctrl + 4 Sets cursor to Data Selection 
mode

` Scale Out

1 Sets cursor to Scale In mode

2 Sets cursor to Screen Reader 
mode

Sets cursor to Data Reader 3
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mode

4 Sets cursor to Data Selection 
mode

5 Sets cursor to Draw Data mode

6 Sets cursor to Add Text Tool

7 Sets cursor to Arrow Tool

8 Sets cursor to Curved Arrow 
Tool

9 Line Tool(with graph active)

F2 Format->Page Properties

F2 Enter the in-place editing mode.

F5 Graph : Refresh the graph

F12 Graph->Layer Contents

Ctrl + Shift + J View->Full Screen

Ctrl + Shift + E Graph: Fit Page to Layer

Up arrow / Down 
arrow

switch plot

Left arrow / Right 
arrow

Move the data selection to the 
left or right, along the plot.

Ctrl + Enter When insert an Image in a 
Graph, double click it to pop-up 
Image window. Then press Ctrl + 
Enter to accept changes and 
close it. This behavior is the 
same as clicking the Return 
button in top-right corner.

Layout
Ctrl + Enter When insert an Image in a 

Layout, double click it to pop-up 
Image window. Then press Ctrl + 
Enter to accept changes and 
close it. This behavior is the 
same as clicking the Return 
button in top-right corner.

Zoom, Pan and Scale
A + Arrow keys Panning the graph page

Ctrl + I View : Zoom In

Ctrl + M View : Zoom Out

A + + Zoom In

A + - Zoom Out

A + Wheel up and Zoom in/out

wheel down or Ctrl 
+ Wheel up and 
wheel down

R + + Zoom In

R + - Zoom Out

S + + Zoom In

S + - Zoom Out

Ctrl + W Restore page to 100% view. 
(91% for Layout page)

Panning on the Graph Layer
X + Wheel up and 
wheel down or X + 
Left click + Move 
the mouse or X + 
Left arrow / Right 
arrow or X + + or 
X + -

Panning in X direction only

X + Shift + Wheel 
up and wheel 
down or X + Shift 
+ Left click + Move 
the mouse or X + 
Shift + Up arrow / 
Down arrow or X + 
Shift + + or X + 
Shift + -

Panning in Y direction only

Z + Wheel up and 
wheel down or Z + 
+ or Z + -

Scale in or out in X direction only

Z + Right click + 
Left click + Move 
the mouse

(drag left or right) Scale in or out 
in X direction only

Z + Shift + Wheel 
up and wheel 
down or Z + Shift 
+ + or Z + Shift + -

Scale in or out in Y direction only

Z + Right click + 
Left click + Move 
the mouse

(drag up or down) Scale in or out 
in Y direction only

D + Wheel up and 
wheel down or D + 
+ or D + -

Scale in or out in Z direction only

Graph Animation
Q Add a frame
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Resize, Rotate and Skew the 3D Graph

This floating toolbar can be activated for 3D OpenGL 
graphs by clicking once inside the graph layer (hint: 
do not click on the actual data plot).

Pressing Ctrl (plus) A selects all graph layers and in a 
3D OpenGL graph, this has the effect of showing the 
3D floating button group. Once the button group is 
displayed, use the TAB key to cycle through available 
tools.

Arrow keys Move the graph layer (including 
all attached objects) on the 
graph page.

X + Arrow keys Resize the 3D graph in the X 
direction.

Y + Arrow keys Resize the 3D graph in the Y 
dimension.

Z + Arrow keys Resize the 3D graph in the Z 
dimension.

Shift + X + Arrow 
keys

Resize the 3D graph in the YZ 
plane.

Shift + Y + Arrow 
keys

Resize the 3D graph in the XZ 
plane.

Shift + Z + Arrow 
keys

Resize the 3D graph in the XY 
plane.

W + Arrow keys Resize the 3D graph in any 
dimension.

X + Arrow keys Rotate the 3D graph around the 
X axis.

Y + Arrow keys Rotate the 3D graph around the 
Y axis.

Z + Arrow keys Rotate the 3D graph around the 
Z axis.

Q + Arrow keys Rotate the 3D graph in screen.

W + Arrow keys Rotate the 3D graph around any 
axes.

R + Move the 
mouse

Drag to rotate the 3D graph in an 
arbitrary direction.

R + Ctrl + Move 
the mouse or R + 
Ctrl + Arrow keys

Rotate the 3D graph around the 
X axis.

R + Shift + Move 
the mouse or R + 
Shift + Arrow keys

Rotate the 3D graph around the 
Y axis.

R + Ctrl + Shift + 
Move the mouse 

Rotate the 3D graph around the 
Z axis.

or R + Ctrl + Shift 
+ Arrow keys

X + Arrow keys Shear the 3D graph in X 
direction.

Y + Arrow keys Shear the 3D graph in Y 
direction.

Tab Toggle the operation modes: 
Resize mode and Rotate mode.

I Increase the speed factor in 
increment of 5%

D Decrease the speed factor in 
increment of 5%

Directional Lighting of the 3D Graph
S + Move the 
mouse or S + 
Arrow keys

Change lighting angles in 
horizontal and vertical planes.

Image
Ctrl + Q Right click and select Add ROI

Ctrl + E Right click on a ROI and select 
Clip

Ctrl + F Right click on a ROI and select 
Apply Scale to Graph

Navigate Multi-Frame Image/Video in the Image 
Window (Do not use these hot keys when 
image/video is playing):

Arrow keys Navigate to the previous/next 
frame when focus is on the 
video. The increment step is 1.

Shift + Arrow keys Navigate to the previous/next 5th 
frame when focus is on the 
video. The increment step is 5.

Shift + Ctrl + 
Arrow keys

Fast-navigate to the 
previous/next 20th frame when 
focus is on the video. The 
increment step is 20.

Ctrl + Arrow keys Navigate to the first/last frame.

Gadgets
O Output the current result.

N Output the results for all curves 
in active layer.

L Output the results for all layers.
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Format
Ctrl + B Toggle Bold on & off

Ctrl + G Greek interpretation of 
characters

Ctrl + I Toggle Italic on & off

Ctrl + U Toggle Underline on & off

Ctrl + > or Ctrl + 
Shift + .

Sel Text: Increase Font

Ctrl + < or Ctrl + 
Shift + ,

Sel Text: Decrease Font

Ctrl + Num + or 
Ctrl + Shift + =

Sel Text: Superscript

Ctrl + Shift + E Format: Fit Page to Layer

Ctrl + = Sel Text: Subscript

Ctrl + Num - Sel Text: SuperSubscript

Ctrl + ' or Ctrl + P Add a full height prime symbol.

Ctrl + Shift + ' or 
Ctrl + Shift + P

Add a full height double prime 
symbol.

Markers
Ctrl + Alt + M Data->Mark Data Range

Ctrl + Alt + N Data->Clear Data Markers

Ctrl + Shift + M Data->Analysis Markers->Hide

Move Lock Position
Ctrl + Shift + F (After performing fitting on 

graph) Data->Lock Position-
>First Point

Ctrl + Shift + K (After performing fitting on 
graph) Data->Lock Position-
>Layer Icon

Ctrl + Shift + L (After performing fitting on 
graph) Data->Lock Position-
>Last Point

Project Explorer
Ctrl + Enter When editing the Comment for 

the windows in the Project 
Explorer sub-panel, press Ctrl + 
Enter to exit edit.

Ctrl + Shift + Move 
the mouse

Duplicate Windows in Project 
Explorer

Horizontal Scroll
For Origin 2024, it supports horizontal scroll by mouse 
wheel including in Graph, Workbook, Matrix, Images 
windows.

Shift + Wheel up 
and wheel down

Scroll right and left in the 
window.

Programming
Ctrl + Shift + Left 
click

Display underlying script in Code 
Builder and display command 
information in Command 
Window and Script Window
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